Welcome, Guest Ministry

Empowering Business, Protecting Investors
Regulator Integrator Facilitator Educator

Register for SMS Alerts   "Presently, this facility is applicable only for Annual Filing eForms i.e. 20B, 23AC, 23ACA, 66 and 21A."
Important Message MCA New link

All users using below mentioned services on MCA21 are required to have Windows XP ( SP3 )/ Windows Vista/Windows 7/Windows 8 and JRE 6u30 updated version 30 installed on their machine -

  • Any user logging on MCA21 using a DSC
  • Any existing registering/updating a DSC
  • Any new user registering using a DSC

Download JRE 6u30 updated version 30 from the following link Click here to download

This is required as part of the interoperability initiative of the Controller Of Certifying Authorities, India (CCA),for enhancing security for Digital certificates.



User ID     *:
Password *:
Category  *:
Use Certificate 
Enter Characters shown below  *:

*Mandatory Field
Submit
New User Forgot Password
Update Certificate
Processing...