•  
Prerequisite Software for efiling

For e-Filing on MCA21 your Computer must have the following components installed:
 
Windows 2000 / Windows XP / Windows Vista / Windows 7/ Windows 8

All users using below mentioned services on MCA21 are required to have Windows XP ( SP3 )/ Windows Vista/Windows 7/ Windows 8 and JRE 6u30 (Java Runtime Environment) installed on their machine -

  • Any user logging on MCA21 using a DSC
  • Any existing user registering/updating a DSC
  • Any new user registering using a DSC
Internet Explorere v6.0 and above, Google Chrome, Mozilla Firefox

Adobe Reader from version 7.5 to version 10.1.4

JRE 6u30 (Java Runtime Environment)

Click on the Explorer, Adobe Reader and JRE icons to download these now. MCA External Link

Important Note: Kindly ensure that
  • The pop-ups are enabled in your machine so that any message generated by the application gets displayed.
  • Adobe Reader is installed so that the content avialable in .pdf format is readable.